Symptoms:
You start a backup plan for the first time. After the first backup has not completed (for any reason), you want to delete this incomplete archive, but cannot find it under Backups.
Or you realize, that the space used in Cloud is larger than your backups occupy:
Cause:
Incomplete backups are not displayed in Backup Management Console.
Solution
Incomplete backups can be deleted in Web Restore Console:
1. In Devices, select the machine you want to delete backups for.
2. Click Recovery:
3. Click More ways to recover:
4. Click Download files
6. Click Show incomplete backups: